Due to technical issues with our Customer Service phone line, we can only help with lost or stolen cards at this time. If your call is about something else, please call us back later. Our sincere apologies for any inconvenience caused. Thank you for your patience.
Posted May 15, 2026 - 17:41 BST
Investigating
We're currently experiencing some delays for customers trying to get through to our Customer Service team, which may result in calls taking longer than usual to be answered. Our apologies for any inconvenience caused. Thank you for your patience.
Posted May 15, 2026 - 17:31 BST
This incident affects: Customer Service phone line.