Customer service phone lines intermittent

Incident Report for Zempler Bank

Resolved

This incident has been resolved.
Posted Jun 24, 2025 - 15:14 BST

Investigating

Due to a technical issue, some customers may experience difficulties connecting to our customer service phone lines. We're working to fix this as quickly as possible.
Posted Jun 24, 2025 - 12:35 BST
This incident affected: Customer Service phone line.