Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 18, 2026 - 21:00 GMT
Scheduled
Please be aware that we have some upcoming maintenance in the evening of Wednesday 18th March. Between the hours of 21:00 - 23:30 the following services will be impacted.
For up to 30 minutes: - Inbound & outbound payments
For up to 5 minutes: - Access to Bank app & Online Banking - Our customer service automated phone line - New applications - Customer communications (inc. Email & SMS) - Open Banking
We apologise for any inconvenience caused.
Posted Mar 18, 2026 - 14:29 GMT
This scheduled maintenance affected: Customer communication, Zempler Bank app, Zempler Online Banking, Customer Service phone line, Receiving money, Sending money, New applications, and APIs.