Mobile and Online Banking Outage

Incident Report for Zempler Bank

Resolved

This incident has been resolved.
Posted Apr 02, 2025 - 08:16 BST

Investigating

We’re currently experiencing issues with customers being able to log in to the Zempler Bank app. Our team are working on fixing this as a matter of urgency. We’re very sorry for any inconvenience caused.
Posted Apr 02, 2025 - 07:26 BST
This incident affected: Zempler Bank app and Zempler Online Banking.