Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 27, 2026 - 22:01 BST
Scheduled
Please be aware that we'll be performing some planned maintenance on the evening of Monday 27th April. Between 22:00 - 00:00, the following services will be impacted for up to 15 minutes: - Access to the Bank app & Online Banking - Access to Debit transaction history via the Bank app, Online Banking and the automated customer service phone lines - Open Banking
We apologise for any inconvenience caused.
Posted Apr 27, 2026 - 15:43 BST
This scheduled maintenance affected: Zempler Bank app, Zempler Online Banking, Customer Service phone line, and APIs.