Zempler Credit Card

Incident Report for Zempler Bank

Resolved

Supplier resolved the issue and service back to BAU
Posted Oct 26, 2025 - 10:24 GMT

Investigating

We are currently experiencing issue in serving customer Credit Card complaints due to an issue with our Supplier.
We are working on priority with Supplier to resolve issue.
Posted Oct 26, 2025 - 08:47 GMT
This incident affected: Credit card.