Online Banking & international payments

Incident Report for Zempler Bank

Resolved

This incident has been resolved.
Posted Apr 01, 2025 - 13:09 BST

Update

We are continuing to investigate this issue.
Posted Apr 01, 2025 - 13:08 BST

Update

Online Banking has now been restored
Posted Apr 01, 2025 - 12:02 BST

Update

We are continuing to investigate this issue.
Posted Apr 01, 2025 - 11:45 BST

Investigating

We’re currently experiencing issues with customers being able to log in to Online Banking as well as being able to send international payments. Our team are working on fixing this as a matter of urgency. We’re very sorry for any inconvenience caused.

If you need to access your account during this time, please use the Zempler Bank app.
Posted Apr 01, 2025 - 11:43 BST
This incident affected: Zempler Online Banking and International payments.