Zempler Bank app unavailable

Incident Report for Zempler Bank

Resolved

This incident has been resolved.
Posted Jul 15, 2026 - 03:05 BST

Update

We are continuing to investigate this issue.
Posted Jul 15, 2026 - 03:05 BST

Investigating

We’re currently experiencing issues with customers being able to log in to the Zempler Bank app. Our team are working on fixing this as a matter of urgency. We’re very sorry for any inconvenience caused.
Posted Jul 15, 2026 - 02:56 BST
This incident affected: Zempler Bank app and Zempler Online Banking.