Online card purchases

Incident Report for Zempler Bank

Resolved

This incident has been resolved.
Posted Mar 11, 2025 - 19:33 GMT

Investigating

We’re currently experiencing issues with online card authorisations, which means some purchases online may be not working. Our team are working on fixing this as a matter of urgency. We’re very sorry for any inconvenience caused.
Posted Mar 11, 2025 - 17:52 GMT
This incident affected: Debit card.