Inbound payments

Incident Report for Zempler Bank

Resolved

This incident has been resolved.
Posted May 18, 2026 - 16:31 BST

Investigating

We’re currently experiencing intermittent issues with inbound payments, which means that you may not be able to receive money into your account at this time. Our team are working on fixing this as a matter of urgency. We’re very sorry for any inconvenience caused.
Posted May 18, 2026 - 13:03 BST
This incident affected: Receiving money.