Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 04, 2025 - 21:00 BST
Scheduled
Please be aware that we'll be carrying out some planned maintenance in the evening of Wednesday 4th June. Between 21:00 – 23:59 the following services may be affected for up to 90 minutes:
- Inbound & outbound payments - Access to the Bank App and Online Banking - New applications - Open Banking - Our automated customer service phone lines (please note that our lost and stolen line will still be operational)
We apologise for any inconvenience caused.
Posted Jun 04, 2025 - 16:44 BST
This scheduled maintenance affected: Zempler Bank app, Zempler Online Banking, Customer Service phone line, New applications, and APIs.