Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 07, 2025 - 22:00 GMT
Scheduled
Please be aware that one of our third party providers will be carrying out some planned maintenance on evening of Sunday 7th December. Between 22:00 - 00:00, the following services will be impacted for up to 90 minutes: · Inbound & outbound payments · Online payments · Access to balance via the Bank App & Online Banking · Access to balance via our automated customer service phone line
We apologise for any inconvenience caused.
Posted Dec 03, 2025 - 12:37 GMT
This scheduled maintenance affected: Zempler Bank app, Zempler Online Banking, Customer Service phone line, Receiving money, Sending money, and Debit card.