Zempler Bank app unavailable
Incident Report for
Zempler Bank
Resolved
This incident has been resolved.
Posted
Jun
13
,
2025
-
20:34
BST
Update
We are continuing to work on a fix for this issue.
Posted
Jun
13
,
2025
-
20:30
BST
Identified
We are currently running with issues with out third party provider, working with them to restore as soon as we can.
Posted
Jun
13
,
2025
-
20:25
BST
This incident affected: Zempler Bank app, Zempler Online Banking, Sending money, Debit card, and APIs.
×
Subscribe to Incident
Subscribe to updates for
Zempler Bank app unavailable
via . You'll receive .