Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 22, 2025 - 22:00 BST
Scheduled
Please be aware that one of our 3rd party providers has some planned maintenance on Sunday 22nd June, until Monday 23rd June. From 22:00 on Sunday to 01:30 on Monday, the following services will be affected for 120 minutes:
- Inbound & outbound payments - Debit card payments in-store & online - Debit card transaction history via Bank app, Online Banking and the automated customer service phone lines
We apologise for any inconvenience caused.
Posted Jun 20, 2025 - 15:01 BST
This scheduled maintenance affected: Zempler Bank app, Zempler Online Banking, Customer Service phone line, Receiving money, Sending money, and Debit card.