Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 05, 2025 - 00:00 GMT
Scheduled
Please be aware that one of our third party providers will be carrying out some planned maintenance in the early hours of Wednesday 5th March. Between 00:00 – 00:30, the following services will be affected for up to 30 minutes.
- Inbound & outbound payments - Debit card payments in-store and online - Debit transaction history via the Bank app, Online banking and our automated customer service phone line
We apologise for any inconvenience caused.
Posted Mar 04, 2025 - 17:17 GMT
This scheduled maintenance affected: Zempler Bank app, Zempler Online Banking, Customer Service phone line, Receiving money, Sending money, and Debit card.