App logins
Incident Report for
Zempler Bank
Resolved
This incident has been resolved.
Posted
Apr
02
,
2025
-
11:06
BST
Update
We are continuing to investigate this issue.
Posted
Apr
02
,
2025
-
11:05
BST
Investigating
We're aware of an issue preventing some customers from being able to log in to the app or reset their passwords. Our team is working to resolve this as quickly as possible. We're sorry for any inconvenience caused.
Posted
Apr
02
,
2025
-
09:54
BST
This incident affected: Zempler Bank app.
×
Subscribe to Incident
Subscribe to updates for
App logins
via . You'll receive .